AccueilVersion Calc 1.x Version Calc 2.x Présentation Calc 3.xBien débuter Calc Fonctions Calc Exercices Calc FormulairesAstuces CalcPrécisions calculsLa bonne formuleProgrammation BasicLiens diversDéfinitionsRecherche sur siteHumourInfos, news

BIEN DEBUTER CALC 3. Opérations de base, B.A. BA




Accès direct : Menu débuter, Grand(e) Débutant(e), Largeur colonnes, Lignes et colonnes, Copie et recopie, Liste de tri, Opérations de base, Opérateurs, Adressage, Personnalisation barres, Mise en forme cellules, Formatage conditionnel, Thèmes & AutoFormat, Audit, Cible, Scénario, Solveur, Filtres, Formatage nombres, Rechercher - Remplacer, Pilote de données, Diagrammes, Gallery, Imprimer, Propriétés fichier, Options Calc, Transferts Calc-Writer, Export PDF,


 

OOo3.x - LibO   Pour OOo1.x & OOo2.x, cliquez ici.

Choisissez votre style d'icônes : Galaxy (par défaut dans OOo), Industriel (absent dans LibO), Cristal, Tango (par défaut dans LibO), Oxygène, Classique. Pour modifier vos réglages, voir comment changer le jeu d icônes.


Il n'est pas nécessaire de maîtriser un tableur pour les opérations élémentaires.

 

 

 

 

Voyons quelques règles simples.

On peut écrire soit dans la ligne de saisie de la barre de formule, soit directement dans la cellule de son choix. Ici on fait nos tests dans la cellule A1, mais on aurait très bien pu choisir n'importe quelle cellule.

Pendant l'écriture, textes ou valeurs sont ajustés à gauche. Ce n'est que lorsqu'on validera nos données par la touche Entrée ou Return que le tableur interprétera s'il s'agit de texte, de valeur ou de fonctions.

 

Ici c'est un texte qui est interprété. Il est aligné à gauche.

Ici c'est une valeur qui est interprétée. Elle est alignée à droite.

 

   

Voici maintenant un exemple d'erreur possible. Un alignement à gauche et un à droite. Pourquoi ?

A cause de la décimale. Le tableur exige une virgule (pour la langue française) pour comprendre qu'il s'agit d'une valeur. Pour lui 123.45 n'est qu'un quelconque texte.

 

    Pour une addition simple, on peut écrire directement dans la cellule. Le fait de commencer l'écriture par le symbole = signifie qu'on veut faire un calcul ou entrer une fonction. Le résultat est immédiat.

Si vous aviez tapé : 2+3, il n'y aurait pas de résultat, puisque le tableur comprendrait qu'il s'agit d'un texte.

    On peut aussi tester la multiplication.

    Ou la division...

Attention aux mélanges. Testez ces 2 exemples qui donnent des résultats différents. Ceci est dû à la priorité différente des opérateurs. En cas de doute, n'hésitez pas à utiliser les parenthèses.

 

Progressons un peu... en B2 et B3, inscrivons les valeurs 2 et 3. Puis pour les additionner, utilisons le système d'addition du tableur. Entrons la formule : =b2 + b3

A partir de cet instant vous pouvez bénéficier de l'avantage indéniable du tableur. Si vous modifiez la valeur d'une cellule, le résultat est immédiatement recalculé et affiché. (Au cas où le recalcul ne fonctionne pas il faut activer le mode recalcul automatique ou appuyer la touche F9).

Après la validation, on peut faire le test suivant. On clique sur la formule dans la ligne de saisie. Immédiatement la formule apparaît avec encadré de couleurs différentes les cellules concernées par l'opération. C'est une excellente méthode pour rechercher des erreurs dans des formules complexes.

Pour faire une série d'additions, on peut faire comme dans cet exemple, additionner cellule par cellule. Ca marche, mais c'est long. Imaginez une longue colonne de chiffres à additionner !

Vous pouvez comme précédemment vérifier votre formule.

Il y a quand même plus simple. Utilisez l'icône somme de la barre de formule.

Immédiatement le tableur va comprendre qu'il faut additionner les cellules numériques non vides proches. Notez que cette fois-ci, c'est la zone de cellules concernées qui est encadrée. Notez aussi la forme de la formule = SOMME(B2:B6)

B2:B6 signifie que sont concernées les cellules B2, B3, B4, B5 et B6.

Autre possibilité : il suffit de sélectionner les cellules concernées et cliquer sur l'icône de la barre de formule.

Il existe une possibilité de connaître le résultat de l'addition sans pour autant créer de formule. Sélectionnez la zone concernée. Le résultat est visible dans la barre d'état sous réserve que la fonction Somme soit cochée.

Ce n'est bien sûr qu'un minimum des possibilités. Vous trouverez de multiples fonctions mathématiques, de dates, de texte, d informations.

 

 

 


Pour aller plus loin

 

 

 

Le vrai débutant pourra passer directement à la page suivante, bien que cette notion, non indispensable, soit utile.

   

Le tableur Calc facilite les additions avec l'icône de la barre de formule. Les valeurs à additionner sont automatiquement sélectionnées, comme sur les exemples suivants.

 

Mais pour aller plus loin, nous avons ajouté les valeurs 10 et 11 en B6 et B7, puis de nouveau cliqué sur l'icône Somme. Seules les deux dernières valeurs sont sélectionnées.

   

Ultime avantage. Si à nouveau vous cliquez l'icône Somme, seuls les deux totaux sont additionnés. Dans ce dernier cas, regardez attentivement l'écriture de la formule. On écrit :

=SOMME(B8;B5) et non =SOMME(B8:B5)

STOP Avez-vous vu la différence ? Elle est importante.

Réponse Le séparateur est le point-virgule et pas les deux points.

 

Cette dernière formule =SOMME(B8;B5) mérite des explications. Le point virgule sert à séparer les plages de données. Il est possible d'écrire la formule comme suit =SOMME(B6:B7;B2:B4). Ce sera strictement identique. Comparez avec la solution précédente.

A noter Vous pouvez écrire vos formules avec un espace après le point virgule. Votre formule n'en sera que plus lisible. Attention, c'est impossible après les deux points.

 

   

Dernier point : si les données sont en ligne, le tableur détecte automatiquement la plage à sélectionner. Mais dans le cas où l'on trouve des données en lignes et en colonnes, les données en colonnes sont prioritaires.

 




Et maintenant, à vos claviers.


 


 

Ce site n'est plus mis à jour. Merci aux nombreux visiteurs depuis 2003. Consultez le Wiki LibreOffice.
   

Le tableur Calc par l'exemple : christianwtd@free.fr
Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 2.0 France License.

  .

Site optimisé pour Firefox

Dernière modification : 07/02/2011 à 16h53


Compteur de visite temps réel LERAPIDE

Compteur non certifié