AccueilVersion Calc 1.x Version Calc 2.x Présentation Calc 3.xBien débuter Calc Fonctions Calc Exercices Calc FormulairesAstuces CalcPrécisions calculsLa bonne formuleProgrammation BasicLiens diversDéfinitionsRecherche sur siteHumourInfos, news

FONCTIONS CALC. Fonctions texte

 




Accès direct : Menu fonctions, texte, dates et heures, logiques, mathématiques, base de donnèes, financières, add-in, statistiques 1, statistiques 2, matrice, classeur, informations, OPERATION.MULTIPLE,

 

NOTA Les syntaxes des fonctions sont notées de cette manière (exemple) : =FONCTION(argument obligatoire 1; argument obligatoire 2 ; argument en option 3; argument en option 4)
Sauf cas particuliers, les paramètres optionnels peuvent être ignorés s'ils ne sont pas suivis d'autres paramètres. Par exemple, on peut ignorer les arguments 3 et 4 mais pas l'argument 3 si on utilise l'argument 4.

Fonctions Syntaxe Exemple Résultat Commentaires
ARABE
ARABIC
=ARABE(Texte) =ARABE("CXX") 120 Donne la valeur d'un nombre en chiffres romains. Valeur maxi : MMMCMXCIX (3999) § ROMAIN
ASC
ASC
=ASC(texte)     Convertit des caractères ASCII et katakana pleine-chasse en caractères demi-chasse, et retourne une chaîne de texte.
BAHTEXTE
BAHTTEXT
=BAHTTEXTE (nombre) = BAHTTEXTE(5)
Retourne un nombre en texte thaï. S'écrit BAHTTEXT dans les anciennes versions OOo
BASE
BASE
=BASE(Nombre; Base; Longueur_min) =BASE(100;2;8) 01100100 Retourne un nombre dans la base choisie.
nombre : nombre entier positif à convertir.
Base : base du système de nombre (entier positif entre 2 et 36).
longueur_minimum : longueur minimum des caractères créés. Ajoute éventuellement des zéros à gauche pour ajuster à la longueur souhaitée.
§ DECIMAL
CAR
CHAR
=CAR(Nombre) =CAR(65) A Permet l'affichage des caractères par leurs codes. Valeurs possibles de 0 (32 en pratique) à 255. Les codes supérieurs à 127 dépendent du codage de votre système. § CODE, UNICAR
=CAR(97) a
CHERCHE
SEARCH
=CHERCHE(texte cherché; texte; position) =CHERCHE("sera"; "L'été sera chaud"; 1) 7
Voir exemples avec caractères génériques
Donne l'emplacement d'un texte cherché dans une chaîne. Position, facultatif, indique le point de départ de recherche. La recherche ne respecte pas la casse (majuscules / minuscules). § TROUVE
Ne pas confondre avec RECHERCHE
CNUM
VALUE
=CNUM(texte) =CNUM("12345") 12345 Convertit une chaîne de caractères en nombre. Erreur possible, voir Erreur N et CNUM.
=CNUM("3 1/4") 3,25 (fraction)
=CNUM("15%") 0,15
=CNUM("10:45:23") 0,45 (suivant affichage. Explications ici)
CODE
CODE
=CODE(texte) =CODE("Bonjour") 66 Renvoie le code décimal du 1er caractère de la chaîne. Dans cet exemple, le code 66 pour la lettre B. Les codes supérieurs à 127 dépendent du codage de votre système. § CAR, UNICODE
CONCATENER
CONCATENATE
=CONCATENER(Texte 1; ...; Texte 30) =CONCATENER("Bonjour "; "monsieur "; "et "; "madame") Bonjour monsieur et madame Permet d'assembler jusqu'à 30 chaînes de textes. Le symbole & est préférable sauf pour conserver la compatibilité.
Attention au deuxième exemple, ce n'est pas une addition ! Les valeurs sont transformées en texte et assemblées. Dans cet exemple 25 est un texte.
="Bonjour " & "monsieur " & "et " & " madame"
= CONCATENER(2; 5) 25
= 2 & 5
CTXT
FIXED
=CTXT(nombre; décimales; séparateur milliers) =CTXT("12345"; 0; 1) 12345 Arrondit un nombre de n décimales. Séparateur milliers (0 ou 1) facultatif. Si égal à 0, ou non défini, les séparateurs de milliers définis de l'environnement linguistique actif s'affichent.§ ARRONDI, TEXTE, CNUM
=CTXT("12345"; 1; 1) 12345,0
=CTXT("12345"; 3) 12 345,000
DECIMAL
DECIMAL
=DECIMAL(Texte; Base) =DECIMAL("01100100"; 2) 100 Convertit un texte d'un système de numération en nombre entier positif dans la base spécifiée. La base doit être comprise entre 2 et 36. § BASE
=DECIMAL("FF"; 16) 255
DROITE
RIGHT
=DROITE(texte; nombre) =DROITE("bonjour"; 4) jour Extrait n caractères à droite d'une chaîne. § GAUCHE, STXT
EPURAGE
CLEAN
=EPURAGE(texte) =EPURAGE(texte)   Elimine tous les caractères non imprimables. Les espaces ne sont pas supprimés. § SUPPRESPACE
EXACT
EXACT
=EXACT(texte 1; texte 2) =EXACT("Bonjour"; "bonjour") FAUX Compare 2 chaînes. Dans l'exemple retourne FAUX (différence majuscule / minuscule). Equivalent à ="Bonjour" = "bonjour". § DELTA
FRANC
DOLLAR
=FRANC(nombre; n. décimales) =FRANC(123,453; 2) 123,45 € Le symbole monétaire du système est appliqué. L'arrondi est fait à n décimales. § EUROCONVERT
GAUCHE
LEFT
=GAUCHE(texte; nombre) =GAUCHE("bonjour"; 3) bon Extrait n caractères à gauche d'une chaîne. § DROITE, STXT
JIS
=JIS(texte)     Convertit les caractères ASCII et katakana (japonais) demi-chasse en pleine chasse. § CAR
MAJUSCULE
UPPER
=MAJUSCULE(texte) =MAJUSCULE("Bonjour Madame") BONJOUR MADAME Convertit le texte en majuscules, y compris les caractères accentués. § MINUSCULE, NOMPROPRE
=MAJUSCULE("L'été à la plage") L'ÉTÉ À LA PLAGE
MINUSCULE
LOWER
=MINUSCULE(texte) =MINUSCULE("Bonjour Madame") bonjour madame Convertit le texte en minuscule. § MAJUSCULE, NOMPROPRE
NBCAR
LEN
=NBCAR(texte) =NBCAR("L'été à la plage") 16 Compte le nombre de caractères d'une chaîne.
=NBCAR(8,1234) 6 (nombre de chiffres et séparateur décimal)
=NBCAR(A1) 6 (si A1 contient par ex 8,1234. Sans effet sur le format d'affichage)
NOMPROPRE
PROPER
=NOMPROPRE(texte) =NOMPROPRE("paul émile victor") Paul Émile Victor Passe en majuscule la première lettre de chaque mot d'une chaîne, et le reste en minuscule. § MAJUSCULE, MINUSCULE
=NOMPROPRE("PIERRE HENRI") Pierre Henri
REMPLACER
REPLACE
=REMPLACER(texte; position; longueur; nouveau texte) =REMPLACER("L'été sera chaud"; 12; 5; "humide") L'été sera humide Remplace une chaîne de caractères, complétement ou partiellement, par une autre. § CHERCHE, STXT, SUBSTITUE, SUPPRESPACE
REPT
REPT
=REPT(texte; nombre) =REPT("LibO "; 2) LibO LibO Répète une chaîne de caractères n fois.
=REPT("OOo "; 2) OOo OOo
ROMAIN
ROMAN
=ROMAIN(nombre; mode) =ROMAIN(345) CCCXLV Convertit un nombre en chiffres romain. Valeur maxi : 3999. § ARABE
Nombre : nombre à convertir
Mode : degré de simplification : plus la valeur est élevée, plus le nombre en chiffres romains sera simplifié.
=ROMAIN(999; 0) CMXCIX
=ROMAIN(999; 1) LMVLIV
=ROMAIN(999; 2) XMIX
=ROMAIN(999; 3) VMIV
=ROMAIN(999; 4) IM
ROT13
GETROT13
=ROT13(texte) =ROT13("mon secret") zba frperg Codage d'une chaîne par rotation de 13 caractères. Le décodage se fait par une 2ème application de la fonction.
=ROT13(ROT13("mon secret")) mon secret
STXT
MID
=STXT(texte; début; nombre) =STXT("L'été sera chaud"; 7; 4) sera Extrait une chaîne de n caractères depuis la position indiquée (début). § CHERCHE, DROITE, GAUCHE, TROUVE
SUBSTITUE
SUBSTITUTE
=SUBSTITUE(texte; texte cherché; nouveau texte; occurrence) =SUBSTITUE("L'été sera chaud";"chaud";"humide";1) L'été sera humide Change un texte par un autre dans une chaîne. Occurrence, facultatif, indique à quelle occurence de la chaîne recherchée on fera le remplacement. § REMPLACER
=SUBSTITUE("bleu bleu"; "bleu"; "rouge") rouge rouge
=SUBSTITUE("bleu bleu"; "bleu"; "rouge"; 1) rouge bleu
=SUBSTITUE("bleu bleu"; "bleu"; "rouge"; 2) bleu rouge
SUPPRESPACE
TRIM
=SUPPRESPACE(texte) =SUPPRESPACE(" bonjour à tous ") bonjour à tous Supprime tous les espaces placés en début et fin de chaîne de caractères. § EPURAGE
Attention. Les espaces insécables ne sont pas traités. Il faut contourner avec une formule du genre =SUPPRESPACE(SUBSTITUE(cellule; CAR(160); CAR(32)))
T
T
=T(valeur) =T(10)   Convertit un nombre en chaîne vide. Sans effet sur une chaîne existante. § CNUM, N
=T("10") 10
TEXTE
TEXT
=TEXTE(nombre; format texte) =TEXTE(1000; "0") 1000 Convertit un nombre en texte au format choisi. § CNUM, CTXT, T
=TEXTE(1000; "0 000,00") 1 000,00
=TEXTE(0,25; "#,000") ,250
=TEXTE(0,25; "0,000") 0,250
=TEXTE(38000; "JJ MM AAAA") 14 01 2004
=TEXTE(38000; "JJJ JJ MMMM") mer. 14 janvier
=TEXTE(0,147; "HH:MM:SS") 03:31:41
=TEXTE(0,147; "HH\h MM\m SS\s") 03h 31m 41s
TROUVE
FIND
=TROUVE(texte cherché; texte; position) =TROUVE("et"; "Bonjour monsieur et madame") 18 Cherche une chaîne de caractères dans une autre chaîne. Position, facultatif, donne le point de départ. TROUVE respecte la casse (majuscules / minuscules). § CHERCHE
=TROUVE(92; 3,1415926535) 7
UNICAR
UNICHAR
=UNICAR(nombre) =UNICAR(931)  Σ Libo - OOo 3.2 -> Convertit un nombre (entre 0 et 1114111 en décimal ou 0 et 10FFFF en hexadécimal) en un caractère ou une lettre Unicode. $ CAR, UNICODE
=UNICAR(934) Φ
=UNICAR(65) A
UNICODE
UNICODE
= UNICODE(texte) =UNICODE("Σ") 931 LibO - OOo 3.2 -> Retourne la valeur numérique (décimale) d'un caractère. § CODE, UNICAR
=UNICODE("Φ") 934
=UNICODE("A") 65


 

 

 

Fonction CHERCHE et caractères génériques

      

 

Quelques exemples d'utilisation de caractères génériques dans la fonction CHERCHE :
Ligne 2, on cherche 5 chiffres, quelqu'ils soient.
Ligne 3, on cherche un mot commençant avec av.
Ligne 4, on cherche les 10 caractères suivant un ir.
Ligne 5, on cherche les 10 caractères suivant un code hexadécimal 61 (la lettre a minuscule).
Ligne 6, on cherche les 10 caractères à partir de nir (fin de avenir).
Ligne 7 on cherche les 10 caractères suivant d'un mot commençant par ave (majuscules ou minuscules).
Ligne 8 on cherche les 10 caractères suivant un des caractères A ou B ou C (majuscules ou minuscules).

 

Ce ne sont que quelques exemples d'applications des caractères génériques dans les fonctions. Plusieurs fonctions sont concernées comme RECHERCHE, RECHERCHEH, RECHERCHEV, NB.SI, les fonctions base de données.
Plus de détails sur les caractères génériques sur les pages Bien débuter :
OOo1.x & 2.x rechercher / remplacer,
OOo 3.x - LibO rechercher / remplacer.

 



 


 

Ce site n'est plus mis à jour. Merci aux nombreux visiteurs depuis 2003. Consultez le Wiki LibreOffice.
   

Le tableur Calc par l'exemple : christianwtd@free.fr
Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 2.0 France License.

  .

Site optimisé pour Firefox

Dernière modification : 25/07/2011 à 11h36


Déjà plusieurs visites sur ce site depuis quelque temps (au moins vous et moi)

Compteur non certifié