AccueilVersion Calc 1.x Version Calc 2.x Présentation Calc 3.xBien débuter Calc Fonctions Calc Exercices Calc FormulairesAstuces CalcPrécisions calculsLa bonne formuleProgrammation BasicLiens diversDéfinitionsRecherche sur siteHumourInfos, news

BIEN DEBUTER CALC. Transferts tableaux Calc - Writer




Accès direct : Menu débuter, Grand(e) Débutant(e), Largeur colonnes, Lignes et colonnes, Copie et recopie, Liste de tri, Opérations de base, Opérateurs, Adressage, Personnalisation barres, Mise en forme cellules, Formatage conditionnel, Thèmes & AutoFormat, Audit, Cible, Scénario, Filtres, Formatage nombres, Rechercher - Remplacer, Pilote de données, Diagrammes, Gallery, Imprimer, Options Calc, Transferts Calc-Writer, Export PDF,


 

OOo1.x & OOo2.x   Pour OOo3.x, cliquez ici.    Normalement cette page n'est plus mise à jour (ancienne version OOo)

Le transfert des tableaux de Calc vers Writer ou de Writer vers Calc peut poser quelques problèmes. Voici quelques exemples simples.

Transfert tableau de Calc vers Writer

 

 

Voici un exemple simple du tableau que nous allons transférer vers Writer. Les titres sont mis en forme (gras, centrés horizontalement et verticalement, avec retour à la ligne automatique).

Les prix unitaires ne sont pas mis en forme, contrairement à la colonne Total (2 décimales avec séparateur des milliers). En la ligne 6, des Totaux est en italique.

Enfin, en B6 est appliqué la formule : =SOMME(B2:B5), et D2 la formule : =B2*C2, cette formule est recopiée vers le bas. En D6, =SOMME(D2:D5)

Après sélection du tableau, nous appliquons un classique copier (Ctrl+C) icône de la barre standard.

Ouvrons un document texte, donc dans Writer. Après un coller (Ctrl+C), icône , voici ce que nous obtenons.

Il ne s'agit que de l'image de notre tableau. Cette notion image est importante. Il est impossible de modifier le contenu du tableau, mais il est en revanche possible d'en modifier la taille. Dans cet exemple, nous étirons l'image vers la gauche, en voici un résultat partiel.

Mais il existe d'autres manières de copier / coller. Maintenez le clic gauche sur l'icône coller, et une liste déroulante de choix apparait:

OpenOffice.org 1.1.3 Classeur, Lien DDE, HTML, Texte formaté ( RTF), Texte non formaté, Métafichier GDI, Bitmap.

Quelques soient les choix, les formules ne seront pas copiées et seront transformées en textes ou valeurs suivant les cas.

L'option DDE ne fonctionne pas sous Linux.

Vous obtiendrez la même chose, via les menus Edition, Collage spécial.

La boite de dialogue Collage spécial fournira les mêmes options de collage.

Les résultats peuvent varier suivant les types de copie. Ici avec lien DDE. Les styles ne sont pas respectés. En revanche une modification dans Calc sera répercutée dans Writer.

La copie HTML respectera presque totalement les styles d'origine.

Avec la copie texte formaté (RTF), tout est parfaitement respecté.

La copie texte non formaté sera la plus simple des copies. Aucun style respecté.

Malgré le désordre apparent, les colonnes existent encore. Pour s'en convaincre, il suffit de cocher Affichage, caractères non imprimables.

 

 

 

Transfert de Writer vers Calc

 

 

Depuis Writer, nous allons copier ce tableau vers Calc. Notez la formule de calculs de somme des quantités. Comme dans les exemples précédents; les formules seront transformées en textes ou valeurs suivants cas.

Après avoir sélectionné et copier le tableau dans Writer, nous appliquons le coller dans Calc. Les styles ne sont pas tous respectés, mais répond globalement aux souhaits. Elle correspond à l'option de collage Texte formaté RTF.

Là aussi nous pouvons, via l'icône coller dérouler un menu.

Si nous utilisons OpenOffice.org 1.1.3 Texte, le résultat est désastreux. Il ne s'agit que d'une image du tableau.

Les options Lien DDE ou Texte non formaté, sont toutes aussi désastreuses. Le tableau se retrouve aligné sur une seule colonne ! Avec l'option Lien DDE, quelque soit la cellule lue, la formule sera la même.

La copie HTML modifiera les styles, mais le tableau sera conforme.





Et maintenant, à vos claviers.

 

 


 


 

Ce site n'est plus mis à jour. Merci aux nombreux visiteurs depuis 2003. Consultez le Wiki LibreOffice.
   

Le tableur Calc par l'exemple : christianwtd@free.fr
Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 2.0 France License.

  .

Site optimisé pour Firefox

Dernière modification : 29/08/2010 à 18h47


Déjà plusieurs visites sur ce site depuis quelque temps (au moins vous et moi)

Compteur non certifié