AccueilVersion Calc 1.x Version Calc 2.x Présentation Calc 3.xBien débuter Calc Fonctions Calc Exercices Calc FormulairesAstuces CalcPrécisions calculsLa bonne formuleProgrammation BasicLiens diversDéfinitionsRecherche sur siteHumourInfos, news

La bonne formule

 

 

Vous n'êtes plus vrai débutant(e) ? cette page est faite pour vous. Comment utiliser la ou les bonnes fonctions, les bonnes formules, pour traiter un problème particulier. A travers ces quelques lignes, des éléments de réflexion.

 

 

Le débutant sur un tableur à de quoi se poser des questions au sujet des fonctions à utiliser. Même en partant du plus simple, pour additionner 2+2, on a le choix entre = cellule1 + cellule2 ou entre =SOMME(cellule1: cellule2). La solution naturelle s'imposera dès qu'il y aura plus de 2 cellules à additionner.

Si certaines fonctions semblent inutiles, elles facilitent bien l'utilisateur. Rares sont celles qui réellement superflues.

 

 

 

Les maths

 

 

 

Impair et pair, 2 fonctions complémentaires et 2 fonctions superflues !
Les fonctions EST.PAIR et EST.IMPAIR sont utiles, équivalentes à :
=ENT(A1/2) = A1/2 pour EST.PAIR
=ENT(A1/2) <> A1/2 pour EST.IMPAIR
mais, EST.PAIR est équivalent de EST.PAIR_ADD et EST.IMPAIR est équivalent de EST.IMPAIR_ADD, donc superflues.


RACINE et PUISSANCE sont presque inutiles, puisqu'elles peuvent se remplacer simplement.
RACINE, on devrait dire 'racine carrée" est l'équivalent de :
= A1^(1/2)
Mais puisqu'on est ici, on peut par cette méthode extraire des racines cubiques:
= A1^(1/3)
ou même n'importe quelle racine !
Vous venez de le voir indirectement en utilisant la fonction PUISSANCE qui est du même coup superflue. Si on reprend les exemples précédents, on peut écrire :
=PUISSANCE(A1; (1/2))
pour
= A1^(1/2)
D'ailleurs, PUISSANCE est strictement équivalente au symbole ^
Donc,
=PUISSANCE(4; 5)
est identique à :
= 4^5 ou encore = 4*4*4*4*4

Il faudra malgré tout porter attention aux fonctions qui se ressemblent, mais ne font que se ressembler, comme ENT, TRONQUE, ARRONDI, ARRONDI.INF, ARRONDI.SUP. Ces fonctions ont des utilités différentes. Il sera prudent de les comparer dans le doute.

Certaines fonctions sont proches du superflu, mais utile :

QUOTIENT est l'équivalent de : =ENT (numérateur / dénominateur)

 

 

 

 

 

Les DATES

 

 

Le calendrier est un vrai casse-tête. Des mois de 30 jours, d'autres de 31 et plus le mois de février qui joue les trouble-fêtes avec ses 28 jours qui deviennent 29 jours tous les 4 ans.

Heureusement, le tableur utilise une méthode simple (au départ) avec un comptage numérique des dates depuis une date de référence. Ainsi depuis le 30/12/1899 et jusqu'à aujourd'hui, il s'est écoulé 42943 jours. Ainsi pour travailler simplement nous pourrions dire, nous somme le 42943 au lieu du 27/07/2017.
Mais, inutile d'inventer un nouveau calendrier, d'autant plus que Calc sait traduire ces nombres en date claire et en formats divers.

Pour nous aider dans nos calculs, JOURSDANSMOIS va répondre simplement au nombre de jours mensuels.
=JOURSDANSMOIS(A1)
remplace avantageusement :
=JOUR(DATE(ANNEE(A1); MOIS(A1) + 1; 0))

 

NO.SEMAINE est une de ces fonctions indispensables, même s'il faut se plonger dans la norme ISO 8601
=NO.SEMAINE(A1;1)
Remplace :
=ENT(MOD(ENT((A1-2) /7) + 0,6; 52 + 5/28)) + 1

 

ESTBISSEXTILE, est quand même plus simple que son équivalent :
=ET((MOD(A1;100)<>0); OU((MOD(A1;4)=0); (MOD(A1;400)=0)))

 

ESTBISSEXTILE nous dira si nous devons compter un jour de plus dans l'année, donc, en février. Redondance ? Oui !
JOURSDANSMOIS pour février, sera équivalent à 28 + ESTBISSEXTILE
JOURSDANSANNEE est équivalent à 365 + ESTBISSEXTILE

Une autre fonction plus qu'appréciable est DIMANCHEDEPAQUES qui va nous permettre de calculer toutes les fêtes mobiles de notre calendrier actuel. Cette fonction évite les calculs de la date de Pâques

 

Encore un exemple de fonction bien utile ? MOIS.DECALER
Son équivalent en formule approchante est :
=DATE(ANNEE(date entière); MOIS(date entière) + décalage mois; JOUR(date entière))
je parle de formule approchante, parce qu'avec des fins de mois de 31 jours et d'autres moins, il y a imperfection.

 

 

 

TEXTES

 

 

Certaines fonctions sont très semblables :
CHERCHE et TROUVE. Pourtant dans au moins un cas, si vous cherchez un point dans un texte, la fonction TROUVE sera préférable.

NOMPROPRE trouve parfaitement sa place entre MAJUSCULE et MINUSCULE. Supposez, dans la cellule A1, un nom avec des minuscules et des majuscules n'importe où. Pour rattraper cela, il faudrait écrire :
=MAJUSCULE(GAUCHE(A1)) & MINUSCULE(DROITE(A1; NBCAR(A1) - 1))
C'est quand même plus simple d'écrire : =NOMPROPRE(A1)

 

T, fonction peu usitée est pourtant utile:
=T(A1)
ne retourne rien si A1 contient des valeurs et le contenu s'il s'agit de texte. Pour faire équivalent, il faut écrire :
=SI(ESTTEXTE(A1); A1; "")

 

 

 

 

Fonctions superflues

 

 

Certaines fonctions ne sont pas indispensables, mais présentes pour conserver la compatibilité. En voici quelques exemples.

Fonctions Informations Exemples Remplaçables par
CONCATENER Permet d'assembler jusqu'à 30 chaînes de textes. =CONCATENER("Bonjour "; "monsieur "; "et "; "madame") & ="Bonjour " & "monsieur " & "et " & madame"
DELTA Teste l'égalité de 2 nombres = DELTA(A1; A2) = =A1 = A2
EXACT Compare 2 chaînes. = EXACT(A1; A2) = =A1 = A2
PUISSANCE Retourne la valeur du nombre élevé à puissance =PUISSANCE(A1; 5) ^ = A1^5
RACINE Retourne la racine carrée d'un nombre positif = RACINE(A1) ^ = A1^(1/2)
SUP.SEUIL teste si un nombre est supérieur ou égal à zéro au seuil fixé =SUP.SEUIL(A1; B1) >= =A1>=B1

DELTA fait presque la même chose que EXACT, mais en moins bien, puisque limité aux valeurs (sinon, erreur).

ACTUELLE est sans doute la plus inutile des fonctions de Calc. Je n'ai toujours pas trouvé sa réelle utilité.

 

 

 

Formules matricielles ou non matricielles ?

 

 

Pour finir, 3 formules qui vont faire la même chose. On cherche le mot texte dans une plage de cellule A1:A10 et on utilise différemment les fonctions SOMMEPROD, NB.SI et SOMME. La principale différence se tient dans la 3ème formule qui s'applique sous forme matricielle (Ctrl + Maj + Entrée). Quelle est la meilleure solution ? Celle qui vous convient le mieux, celle qui vous semblera la plus lisible.


=SOMMEPROD(A1:A10="texte")
=NB.SI(A1:A10; "texte")
{=SOMME((A1:A10)="texte")}

 

 

 

Ce site n'est plus mis à jour. Merci aux nombreux visiteurs depuis 2003. Consultez le Wiki LibreOffice.
   

Le tableur Calc par l'exemple : christianwtd@free.fr
Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 2.0 France License.

  .

Site optimisé pour Firefox


Dernière modification : 06/10/2010 à 16h32


Déjà plusieurs visites sur ce site depuis quelque temps (au moins vous et moi)

Compteur non certifié