AccueilVersion Calc 1.x Version Calc 2.x Présentation Calc 3.xBien débuter Calc Fonctions Calc Exercices Calc FormulairesAstuces CalcPrécisions calculsLa bonne formuleProgrammation BasicLiens diversDéfinitionsRecherche sur siteHumourInfos, news

EXERCICES CALC. Poids Idéal. Version améliorée

 

Accès direct : Poids Idéal 1 Poids Idéal 2

 

 

Vous avez vu la page précédente ? Cette fois-ci nous allons améliorer la facilité d'utilisation et la présentation. Bon alors allons y. Commençons par ouvrir un nouveau classeur.

 

Comme dans la page précédente, nous allons donc entrer les données sexe, taille, poids, âge et morphologie dans les cellules B1 à B5, et les résultats des formules apparaîtront dans les cellules B7 à B12.

Ajustez les largeurs de colonnes (voir hauteur lignes, largeur colonnes)

 

Préparons ensuite des tableaux pré remplis. comme sur cet exemple, à partir de la colonne F, nous créons des données pour sexe, taille, poids, age et morphologie.

La suite est valable pour les versions OOo 1.1.x ou OOo 2.x. Toutefois, pour OOo 2.x, il est possible d'utiliser une méthode plus simple, évoquée à la suite.

 

Méthode OOo 1.1.x et OOo 2.0x

 

 

 

Ensuite, nous allons utiliser les avantages des listes de choix. Dans la barre d'instruments, nous sélectionnons l'icône de zone combinée.

Dans B2 nous allons dessiner la zone de liste. Notez la forme du curseur.

En fin de tracé, voici ce qui apparaît.

Suivie aussitôt de la boite de dialogue Autopilote de zone combinée. Annulez-la.

En revanche, avec un clic droit, sélectionnez Contrôle dans le menu flottant.

Dans l'onglet Données, remplissez la Plage de cellules source et la Cellule liée qui retournera la sélection effective.

Voici ce que vous verrez à la première utilisation.

Voici un exemple de retour de variable.

Pour la suite ? Il suffit de reprendre les mêmes principes.

Il est possible de modifier le nombre de lignes visibles. Dans cet exemple, ce serait plus agréable.

Dans l'onglet Général, modifiez à votre guise le Nombre de lignes (utilisez l'ascenseur vertical pour les options non visibles).

Notez dans Entrées de liste les valeurs lues dans la zone des données.

Et voila le genre de résultat que vous devez obtenir au final. Cependant ce n'est pas fini. Pour les variables Homme, Femme ou Normale, gracile, large, il est utile de les transformer en variables numériques pour faciliter les formules.

Un piège. Quelque chose ne va pas dans les cellules C3, C4, C5. Avant de lire plus loin, essayez de voir ce qui ne va pas.

Les variables taille, poids, age ne sont ici pas numériques. Elles sont normalement alignées à gauche. C'est un signe. Il faut donc également les convertir.

STOP. Quelles sont les formules à appliquer ?

 

Vous avez bien sûr trouvé. Plusieurs solutions sont possibles. Voici celles que je vous propose :

Pour sexe, en D2 : =SI(C2=F2;1;2)

Pour Morphologie, 2 conditions imbriquées suffisent : =SI(C6=J2;1;SI(C6=J3;2;3))

Enfin pour les conversions texte en numérique, on applique la fonction CNUM. Par exemple pour taille : =CNUM(C3)

 

 

 

Méthode pour OOo 2.x

 

 

 

OOo 2.x apporte un plus avec la Validité, déjà présente dans OOo 1.1.x, mais avec en plus l'option Plage de cellules

 

Ensuite dans Source, entrez les cellules à lire. Ici, pour Sexe, donc 2 cellules lues. Ensuite le fait d'activer la cellule (clic, flêches) fait apparaître une flêche à droite de la cellule. Il suffit de cliquer pour faire apparaître la liste choisie.

 

Ici un exemple avec la liste des tailles. A noter un avantage supplémentaire. Il est possible de taper une valeur dans la cellule, sans pour autant s'occuper de la liste.

Nous essayons de conserver la même structure que dans la page précédente pour les formules. A noter un point important par rapport aux zones combinées, les retours valeurs sont bien des valeurs. Il n'est pas utile de les transformer avec CNUM

 

 

 

 

 

 

 

C'est pas fini ? Eh non ! Mais la suite vous pouvez très bien faire seul, il suffit de reprendre les éléments de l'exemple simple de la page précédente.

Une des améliorations évidentes est de masquer les colonnes C et D, puis F à J. Elles ne servent qu'au tableur. Donc si elles sont masquées, on évite tout simplement d'écrire dans ces données.

 


Et maintenant, à vos claviers.

 

 

Ce site n'est plus mis à jour. Merci aux nombreux visiteurs depuis 2003. Consultez le Wiki LibreOffice.
   

Le tableur Calc par l'exemple : christianwtd@free.fr
Creative Commons License
This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 2.0 France License.

  .

Site optimisé pour Firefox


Dernière modification : 29/08/2010 à 18h48


Compteur de visite temps réel LERAPIDE

Compteur non certifié